why do I get no picture on my ps3 when I change HDMI TV?

I had my PS3 working through the HDMI lead on a large HDMI TV.

I then bought a smaller HDMI TV and plugged in my playstation to that (with same HDMI lead). worked fine.

I’ve now moved my PS3 back to my large TV as I have friends coming over. But when I turn on the machine I get ‘no signal’ – I do however have sound but no picture. I’ve tried holding in the power button till I get the second beep but this does not help.

What can I do to fix it?

What’s your suggestion if I want to do this about my PS3?

Ok I had my PS3 for two years now and I was thinking of either calling sony and see if they could clean it for me or I could just opened it myself and clean it myself. The reason why I want to open it is because of all the dust it collects. Last year I changed my hard drive and when I was doing that I saw dust in the PS3 and that’s just the where the hard drive goes and yeah I’m aware that I probably voided the warranty because I changed the hard drive but what do you guys think?

NAT2 to NAT3 PS3 I’ve Tried Everything?

I’ve been trying for a week now to change my settings to achieve NAT2.

Right now I have a WRT54G2 (v1) and I have these ports forwarded

TCP: 80, 443, 5223, 10070-10080

UDP: 3478, 3479, 3658, 10070

I have a static IP set to all the ports that mirrors the IP on my PS3. (192.168.1.50)

I also have the DMZ on my router set to the IP on my PS3.

I have UNUP enabled on my router but disables on my PS3. But I have tried all possible configurations with that.

What do I do?